(global)

Technicka dokumentace k projektu Calculator

(global) Namespace

Namespace hierarchy

Classes

Class | Description
clCalculator | Zakladni vypocetni operace

Enumerations

Enumeration | Description
clCalculator.enActions | Mozne vypocetni akce


clCalculator Class

Zakladni vypocetni operace

For a list of all members of this type, see clCalculator Members.

System.Object
clCalculator

[Visual Basic]
Public Class clCalculator
[C#]
public class clCalculator

Remarks

Trida clCaltulator slouzi pro zakladni matematicke vypocty

Requirements

Namespace: (global) Namespace

Assembly: Calculator.dll

See Also

clCalculator Members | (global) Namespace

Generated from assembly Calculator [1.0.1001.39809]


clCalculator Members

Public Instance Constructors

clCalculator Constructor

Public Instance Properties

getResult | Vraci vysledek vypocetnich operaci
numberA | Clen A
numberB | Clen B

Public Instance Methods

Compute |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

clCalculator Class | (global) Namespace


clCalculator Constructor

[Visual Basic]
Public Sub New( _
   ByVal a As Short, _
   ByVal b As Short _
)
[C#]
public clCalculator(
short a,
short b
);

See Also

clCalculator Class | clCalculator Members | (global) Namespace


clCalculator Properties

The properties of the clCalculator class are listed below. For a complete list of clCalculator class members, see the clCalculator Members topic.

Public Instance Properties

getResult | Vraci vysledek vypocetnich operaci
numberA | Clen A
numberB | Clen B

See Also

clCalculator Class | (global) Namespace


clCalculator.getResult Property

Vraci vysledek vypocetnich operaci

[Visual Basic]
Public ReadOnly Property getResult As Short
[C#]
public short getResult {get;}

Property Value

vysledek vypoctu

See Also

clCalculator Class | clCalculator Members | (global) Namespace


clCalculator.numberA Property

Clen A

[Visual Basic]
Public Property numberA As Short
[C#]
public short numberA {get; set;}

Property Value

Hodnota clenu A

See Also

clCalculator Class | clCalculator Members | (global) Namespace


clCalculator.numberB Property

Clen B

[Visual Basic]
Public Property numberB As Short
[C#]
public short numberB {get; set;}

Property Value

Hodnota clenu B

See Also

clCalculator Class | clCalculator Members | (global) Namespace


clCalculator Methods

The methods of the clCalculator class are listed below. For a complete list of clCalculator class members, see the clCalculator Members topic.

Public Instance Methods

Compute |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

clCalculator Class | (global) Namespace


clCalculator.Compute Method

[Visual Basic]
Public Sub Compute( _
   ByVal operator As enActions _
)
[C#]
public void Compute(
enActions operator
);

See Also

clCalculator Class | clCalculator Members | (global) Namespace


clCalculator.enActions Enumeration

Mozne vypocetni akce

[Visual Basic]
Public Enum clCalculator.enActions
[C#]
public enum clCalculator.enActions

Members

Member Name | Description
multi | Nasobeni
plus | Scitani
divi | Deleni

Requirements

Namespace: (global) Namespace

Assembly: Calculator.dll

See Also

(global) Namespace


(global)Hierarchy

Technicka dokumentace k projektu Calculator

(global) Hierarchy

System.Object
-clCalculator