Pokud jste někdy zavítali do oficiálního adresáře WordPress pro pluginy nebo šablony, určitě vás potěšila na pohled poměrně rozsáhlá nabídka – mohli jste vybírat z více než 15 tisíc pluginů a z více než 1400 šablon. Kolik ale z těchto pluginů a šablon nebylo po vydání první nikdy aktualizováno nebo kolik z nich je určeno pro starší verze WordPressu, které už dnes ale téměř nikdo nepoužívá? V tomto ohledu zajímavou statistiku přináší článek What Lurks in the WordPress Plugin Repository?, kde se například můžete dočíst, že:

  • Více než polovina pluginů není kompatibilní s verzí WordPressu 3.x.
  • 85 % pluginů, které autor článku testoval, obsahovala různá varování (warnings), chyby (errors) nebo komentáře (notices) parseru PHP.
  • Pouze 32 % pluginů z celkového počtu 15000+ se dočkalo v roce 2011 aktualizace.

Celková situace tedy nevypadá nějak zvlášť příznivě a tak bylo rozhodnuto s tím něco udělat. Jak píše Separatista :-) ve článku Zastaralé pluginy a šablony už ve WordPressu nenajdete, během několika posledních dní postupně zmizely z oficiálních adresářů WordPressu všechny „zastaralé“ pluginy a šablony, které nebyly již více než dva roky aktualizovány, a lze očekávat, že další čistky od starých nebo nefunkčních pluginů a šablon budou následovat. Jste zvědaví, jak k velkému zpřehlednění dojde? Já rozhodně ano.

Zdroj: wpmu.org a separatista.net.

Žádný příspěvek v diskuzi

Odpovědět